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Designing a Spreadsheet

* When a spreadsheet is used repeatedly, it
becomes a tool of planning, analysis, and
decision-making

* Must be well designed and flexible to be
effective
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The Trip

* Driving trip to the Arctic Circle from
Chicago

- Make a spreadsheet to figure out how long
it will take and how much it will cost
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ens from: chicage to: inuvik - Google Maps

o
Web Imsges Video Mews Maps Gmal mowv Savea Locations | Sign in | Help
Start scaress End address
OUS € khicagel 2 hauvik Get Directions
Seachthe map  Eind businesses Get directions

Search Results My Maps.
?fﬂa’a Chicago, IL

) Drve: 3,631 mi—about 3 days 14 hours

Figure 15.1 Google map directions for a trip from Chicago, lllinois (green pin),
to Inuvik, Northwest Territories (red pin).
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Design Guidelines

* Focus on Form
— Make the form logical, the layout clean, and
the entries clear and understandable
+ Descriptive info should be on the top and left
* Summary info should be on the bottom and right
— Use different fonts, colors, separate sheet for each table
« Explain Everything

— It should be possible to know immediately
what every cell means
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Initial Spreadsheet: Applying the Rules

 Focus on Form:

— title, authors, completion date, column
headings, color, clean font, data aligned

- Explain Everything:
— comments added to cells (Insert > Comment)

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07
Segment Tme  Mies FuelPriceReport Ul

Chicago to Camington ND 12:02 778 US Chicago $3.59
Camrington to Battleford SK 11:06 620 US Moorehead MN $2.96
Battleford to Fort St. John 11:26 648 CA Moose Jaw SK $1.09
Fort St. John to Waston Lake YK 10:17 555 CA Medicine Hat AB $1.01
Watson Lake to Dawson YK 11:55 601 CA Mi 54 AK Hiway BC $1.21
Dawson to Dawson via AC 14:00 484 CA Mi 54 AK Hiway BC $1.21

Figure 15.2 Initial spreadsheet for the Arctic Circle road trip.

Copyright © 2008 Pearson Education, Inc. Publishing as Pearson Addison-Wesley

15-6

Conditional Formatting

 Cell Value Is Specifications

— Format > Conditional Formatting...
« Change formatting in response to certain conditions
— Can specify one or more conditions

— Can use formulas in the comparison
* Example: bold data greater than average of range
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Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07

~ - -
Segment 1;::3 Miles  Fuel Price Report ::::
Chicago to Carrington ND 12:02 778 US Chicago $3.59
Carrington to Battleford SK 11:06 620 US Moorehead MN $2.96
Battleford to Fort St. John 11:26 648 CA Moose Jaw SK $1.09
Fort St. John to Waston Lake YK 10:17 555 CA Medicine Hat AB $1.01
Watson Lake to Dawson YK 11:55 601 CA Mi 54 AK Hiway BC $1.21
Dawson to Dawson via AC 14:00 484 CA Mi 54 AK Hiway BC $1.21

Figure 15.3 The Arctic Circle road trip spreadsheet with conditional formatting
for “long days.”
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Conditional Formatting (cont)

« Formula Is Specifications

— Allows comparison with cells other than the
one being formatted

A2 cell: =IF(B2>AVERAGE(B$2:B$7), TRUE, FALSE)

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07

Time 2 *  Fuel "
Segment Est. Miles  Fuel Price Report Price
Chicago to Carrington ND 12:02 778 US Chicage $3.59
Carrington to Battleford SK 11:06 620 US Moorehead MN $2.96
Battleford to Fort St. John 11:26 648 CA Moose Jaw SK $1.09
Fort St. John to Waston Lake YK 10:17 555 CA Medicine Hat AB $1.01
Watson Lake to Dawson YK 11:55 601 CA Mi 54 AK Hiway BC $1.21
Dawson to Dawson via AC 14:00 484 CA Mi 54 AK Hiway BC $1.21

Figure 15.4 Conditional formatting to highlight trip Segments, whose Time
Estimate is greater than average.
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Conditional Formatting (cont)

- Distinguish Between the U.S. and Canada

— Italicize fuel cost if fuel price estimate is in
Canadian dollars

E2 cell: =IF(Left(D2,2)="CA", TRUE, FALSE)

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07
. " "
Segment Tme  Miles Fuel Price Report  Fuel

Chicago to Carrington ND 12:02 778 US Chicago $3.59
Carrington to Battleford SK 11:06 620 US Moorehead MN $2.96
Battleford to Fort St. John 11:26 648 CA Moose Jaw SK $1.09
Fort St. John to Waston Lake YK 10:17 555 CA Medicine Hat AB $1.01
Watson Lake to Dawson YK 11:55 601 CA Mi 54 AK Hiway BC $1.21
Dawson to Dawson via AC 14:00 484 CA Mi 54 AK Hiway BC $1.21

Figure 15.4 Conditional formatting to highlight trip Segments, whose Time
Estimate is greater than average.
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Conditional Formulas

« Computing with conditional factors
 Figuring the Amount Paid
— Miles per gallon (22) vs. miles per liter (5.8)
=IF(LEFT(D2,2)="US", E2*C2/22, E2*C2/5.8)

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07

N M M “
Segment Miles FuelPrice Report  [uel " Amount
Chicago to Carrington ND 778 US Chicago $3.59  $126.96
Carrington to Battleford SK 620 US Moorehead MN $2.96  $83.42
Battheford to Fort St. John 648 CA Moose Jaw SK $1.09  $122.23
Fort St. John to Waston Lake YK 555 CA Medicine Hat AB $1.01 $96.55
Watson Lake to Dawson YK 601 CA Mi 54 AK Hiway BC $1.21  $125.28
Dawson to Dawson via AC 484 CA Mi 54 AK Hiway BC $1.21  $100.89

Figure 15.5 Arctic Circle spreadsheet with Amount Paid column added. Notice
that Time Estimate has been hidden, and that a comment noting the
assumption of 22 mpg has been added to Amount Paid heading.
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Conditional Formulas (cont)

¢ Cost in One Currency
— Canadian to US currency exchange rate (0.93)
=IF(Left(D2,2)="CA", F2*0.93, F2)

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07

segment Miles Fuel Price Report  ruel AMOUSt’  cogp

Chicago to Carrington ND 778 US Chicago $3.59 $126.96 $126.96
Carrington to Battleford SK 620 US Moorehead MN $2.96 $83.42 $83.42
Battieford to Fort 5t. John BC 648 CA Moose Jaw SK 51.09 $122.06 $115.71
Fort St. John to Waston Lake YK 555 CA Medicine Hat AB  $1.01  $96.42  $9L41
Watson Lake to Dawson YK GO1 CA Mi 54 AK Hiway BC $1.21 $125.11 $118.60
Dawson to Dawson via Aritic Cir 484 CA Mi 54 AK Hway BC $1.21  $100.75  $95.51
Dawson to Watson Lake YK 601 CA Mi 54 AK Hiway BC $1.21 $12511 $118.60
Waston Lake te Fort St. John BC 555 CA Medicine Hat AB $1.01 $96.42 $91.41
Fort 5t. John to Battleford SK 648 CA Moose Jaw SK $1.09 $122.06 $115.71
Battieford to Carrington ND 620 US Moorehead MN $2.96  $83.42  $83.42
Carrington to Chicago IL 778 US Chicago $3.59 $126.96 $126.96

Total: $1,167.71

Figure 15.6 Arctic Circle spreadsheet completed to the point of producing an
estimate for fuel costs.
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Naming: Symbolic Reference

 Defining Names

— Refer to cells symbolically by name rather
than literally by explicit column/row position

— A name is a word or phrase assigned to a cell
or range of cells (no spaces)
* Name used wherever cell references are used
* Minimizes errors when columns/rows added later
* In Excel 2003

— Insert > Name > Define
— Insert > Name > Apply
* In Excel 2007

— Formulas tab > Define Name
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Define Name Apply Names
Names in workbook: m@ Apply names:
. | X
distance = —
= = ( Close ) ( Cancel )
Add ( Options... )
(_Deete )
Refers to: E lgnore relative/absolute
=Sheetl!SBS2:5B512 [2] ™ Use row and column names

R ———————————————
(a) (b)

Figure 15.7 Name windows: (a) the Define Name window and (b) the Apply Names window.

Copyright © 2008 Pearson Education, Inc. Publishing as Pearson Addison-Wesley 15-14

Naming: Symbolic Reference (cont)

* Applying Names
=|IF(LEFT(D2,2)="US", fuelPrice*distance/22, fuelPrice*distance/5.8)
— Safer, easier to read and understand

- Make Assumptions Explicit

— Assign instance-specific quantities that may
change to cells, give them names, and use
these names in the formulas

* mpg, mpl, exchange rate, # of travelers

=IF(LEFT(priceSrc,2)="US", fuelPrice*distance/mpg,
fuelPrice*distance/mpl)
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"What If" Analysis

» Spreadsheets recalculate everything
whenever a number is changed

- |deal for speculating on the consequences
of change

— Make a change and notice what happens to
the "bottom line"
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"What If" Analysis (cont)

- Direct Experimentation
— Potential risk of making permanent changes to
data and formulas
« Scenarios

— A named alternative to a spreadsheet based
on different inputs

— Aid to understanding changes in plans, like
changes in gas mileage

Scenarios

« Tune-up Scenario
— Excel 2003: Select mpg cell, Tools > Scenarios...
— Excel 2007: Data tab > Data Tools > What-If Analysis

fal Scenario Manager A ib) Edit Scenario
Scenarien Thow Seensio name (=]
W Scxnarion defned. Chosne o e [Tureue ' (Ccancel )
. ) e i,

{ Add.. % 12 ry

Cmis click calls 10 vebect mon-
adjacent hangisg cells

Changing oe
= Commant
([ Merge. ) [Crasted by Alex o 672072007 |
Dl Frctectan
& Prevent changes [ 1ode

Figure 15.8 Dialog box sequence for adding a scenario to the Arctic Circle spreadsheet.
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(c) Scenario Values (d) Scenario Manager
|  Enter values for each of the changing cells. Scenarios: @ s - s
1= [ —  Tuneve | cenario Ssummary
| L mpg 25 Cl
s Current Values: TuneUp
| = I\) Changing Cells:
=2 mpg 22 25
| « Changing cells [ Result Cells:
s: e FuelCost $1,167.71 $1,027.59
@ Notes: Current Values column represents values of changing cells at
time Scenarie Summary Repert vas created. Changing cells fer each
EORNBS R scenario are highlighted In gray.
Created by Alex on 6/23/2007
Figure 15.9 The Scenario Summary sheet showing the
result of the TuneUp scenario.
Figure 15.8 Dialog box sequence for adding a scenario to the Arctic Circle spreadsheet.
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Scenarios (cont)

 Traveling Companions Scenario

— Adding buddies in the car will drop the mpg
but also the cost per person

lal Add Scenari (b) Seenarso Values

Stenaria name @ Enter walues for each of the changing cel.

Emdl+ick cally 19 abect nan-
adjacerd changing ceb.

4
Commenn
Created by Abtx on 6202007 .

Frstection

& Prevent changes [ dade

Figure 15.10 The Extra Passenger scenarios and their effect on ppFuel.
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(c) Scenario Values

Enter values for each of the changing cells. (d)

1. mpg (25

Scenario Summary

5 Current Values: Tuneup Extra Passenger
’ Changing Cells:
3: mpg 22 25 20
buddies 2 2 3
4 Result Cells:
perPerson $583.86 $513.79 $428.16

5

(Caaneel) @R

Figure 15.10 The Extra Passenger scenarios and their effect on ppFuel.
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Analyzing a Model

« Formulating a Model

— Account for all foreseeable costs
« The Model

— Table summarizing the per person expenses
* Reusing Scenarios

— Rerun scenarios to see how the total cost
changes as the number of travelers increases

Copyright © 2008 Pearson Education, Inc. Publishing as Pearson Addison-Wesley 15-23

Trip to the Arctic Circle
by Pat and Alex; completed 23.June. 07

™ 3 " Lodging Contin- " JustIn *
Lodging [ Price gencies Case

Campground 2 25 25 Base Cost  $100.00
Provincial Park 2 20 20 Tires $160.00
Provincial Park 2 20 20

Wildemess: 2 0 o

Hostel@$20 1 20 40

Hostel@$20 1 20 40

Wildemess: 2 0 o

Provincial Park 2 20 20

Provincial Park 2 20 20

Campground 2 25 25

Total $210.00 $260.00
Total Per Person $105.00 $130.00
Camping Yes

Figure 15.11 The lodging and contingency data for the Arctic Circle
road trip.

Trip to the Arctic Circle
by Pat and Alex; completed 23.June.07

Amount Per Scenario Summary

Costs. Person Curent Values: 1 Extra Traveler 2 Extra Travelers

Fuel $583.86 Changing Cells:
Lodging $105.00 mpg 2z Z1 Z0
Contingency $130.00 buddies 2 3 4

Result Cells:

Total 618,86 EstTotal SEIE 86 3599.44 339112
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Analyzing a Model

« A Change in Plans
— Stay in Hostels vs. camping

Scenario Summal

Current 1 Extra 2 Extra Hostel
Values: Traveler Travelers Upgrade
Cha Celis:
mpg 22 21 20 20
buddies 2 3 4 4
5152 25 25 25 18
5153 20 20 20 18
5154 20 20 20 18
$185 [1] 0 0 18
5156 20 20 20 18
$1s7 20 20 20 18
5158 0 o 0 18
$1s9 20 20 20 18
$1810 20 20 20 18
51511 25 25 25 18
camping _|Yes Yes Yes No
Result Celis:
estTotal $818.86 $577.77 $458.62 $566.12

Figure 15.12 Scenario Summary table for the Arctic Circle road trip.
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Analyzing Data Using Filtering

+ Travel Log spreadsheet
— Can use a filter to access subsets of information
(selecting only certain rows from a list) to create a
customized version of a spreadsheet
+ Auto Filtering Technique
— Data > Filter > AutoFilter

— Options for filtering the list based on data in each
column

— Turn off AutoFilter by selecting it again (toggle)
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Road To Arctic Circle and Back: Stops
Pat, Alex, Chi, All

T i i . = N
_When Mo wmere esson M Remark
B/4/07 5:45 1 AIl's house IL Last pick-up 0.00 We're Offt
B8/4/07 6:40 1 Toll Booth IL Alex Fumbles  Alltolls X 285
B/4/07 8:05 1 DriveThru Joe IL  Es Only driver
B8/4/07 9:00 1 Belok W1 Gas & Go Gas A 3450 241
B8/4/07 9:55 1 Madisan Wi Snacks
8/4/07 12:05 1 5t. Paul MN Gas & Go, Eat Gas P 2895 191 Subway
B/4/07 14:45 1 St Cloud MN Stretch/Photo Pretty Here
8/4/07 15:30 1 Sauk Center MN  Snacks
B/4/07 16:55 1 Fergus Fals MN Gas & Go Gas P 2922 205
8/4f07 19:45 1 Fargo ND Photo in ND Pat's First
B/4/07 20:25 1 Valey Ciy ND Supper Junk Food
8/4/07 22:00 1 Carrington ND Stay Night Camp C 2145 Great Start
8/5/07 7:25 2 Carrington ND Gas Gas A 3742 2852
B8/5/07 7:55 2 Sykeston ND Photo Its flat
8/5/07 10:05 2 Minot ND Gas & Go,Snx  Gas X 1964 135 Ice Cream
8/5/07 11:50 2 Portal ND Photo in CA All Pat, 1st
B/5/07 12:25 2 Estevan SK Lunch
8/5/07 13:55 2 Weybum SK Gas & Go, Eat Gas A 3382 151
B/5/07 15:45 2 Moose Jaw SK Snacks 15cream!

Figure 15.13 Start of the Travel Log of the Arctic Circle road trip. Seg. Mo corresponds to a
segment of the ariginal plan (Sheet 1), § refers to who paid a shared expense, Hi is distance
traveled since last fuel.
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Advanced Filtering Technique

« More refined analysis with precise filtering
criteria
« Advanced Filtering Setup

— Add a new column with the same heading as
the column containing the date to be filtered

— Enter a criterion to indicate that values in the
other column by he same name should be
filtered with that criterion
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Advanced Filtering Technique (cont)

« Executing an Advanced Filter
— Select a cell in the column to be filtered
— Data > Filtering > Advanced Search...

« List range: dimension of the list to be filtered

* Criteria range: range covering the heading and the
criterion of setup column

» Copy to: specifies a new place on the spreadsheet
to place the filtered result (optional)

— Restore original table: Data > Filtering > Show All

Copyright © 2008 Pearson Education, Inc. Publishing as Pearson Addison-Wesley

15-29

Advanced Filtering Technique (cont)

* Filtering on Multiple Criteria
— Define multiple setup columns with criteria

— Criteria range in Advanced Filter window is
enlarged to cover all criteria in the setup
columns
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Chicago to Carrington, ND: 778 miles, 12 hrs, 2 minutes
Carrington to Battleford, SK: 620 miles, 11 hrs, 6 minutes
Battleford to Fort St. John, BC: 648 miles, 11 hrs, 26 minutes
Fort St. John to Watson Lake, BC: 555 miles, 10 hrs, 17 minutes
Watson Lake to Dawson, YK: 601 miles, 11 hrs, 55 minutes
Round-trip Dawson to Arctic Circle: 484 miles, 14 hours
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Conditional Formatting

_Condition 1
Cell Valuels  [#) [ between Rl I[2] and T[]
Preview of format to use No Format Set
when condition is true:
) (add>>) (osie.) )
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+  between e

not bety jatting
—
15 equal to
A '.xg '“' LEiEnt not equal to

+ greater than
less than
greater than or equal to
less than or equal to

Price a8

8% Preview of format to usi
$ 3 . 5 9 I when condition is true:

| 620,US Moorehead MN 3£.90 @ GEs) Covemsy

Prices from gasbuddy.com
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Conditional Formatting

Cenditional Formatting

Time :
Contion | Est. & 1
[Cellvaluels %) [ greater than %) |=AvERAGE®BS$2:857) =1 12:02 [ Formula Is 2] E ”E
11:06
D 2 Previ f f i o
e Aasceryz: 11:26 e condhion s AsBbCeYy2Z2
10:17
11:55
) (Add>>) (Delee.. ) (Cancel ) E0KED 14:00 (2) (Add>> ) (Delete... ) o)
T ——
e ™
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Conditional Formatting

Condition 1

Formula Is [=IFLEFT(D2,2)="CA", TRUE, FALSE) =1

Preview of format to use AaBbCcYyZz

when condition is true:

@ (Add >> ) ( Delete... ) @
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Assumptions:
Miles per gallon:

Miles per liter: 5.

22
81

US-Canadian Exchange Rate: 0.948

Travlers:
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Scenario Summary

Report type

@ scenario summary
O Scenario PivotTable

Result cells:

lG15 i[2]
( Cancel ) m
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Total: $1,167.71
Cost Each $583.86

Copyright © 2008 Pearson Education, Inc. Publishing as Pearson Addison-Wesley

15-40




Scenario Summary

Report type

e Scenario summary
O Scenario PivotTable

Result cells:

I estTotal ] El
o

Total
Total Per Person

Camping

Yes

$210.00
$105.00
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B/4/07 6:40 1 Tol Booth L Alex Fumbles  Altols X 285
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8/4/07 5:45 1 A¥s house IL Last pick-up 0.00 We're Offt
8/4/07 6:40 1 Toll Booth IL Aex Fumbles Altols X 285
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Alex Fumbles | et Duscsdeg L85
Espresso « O AR
Gas 8.Go ShemTep 180 1,50
S T
Gas B Go, Eat | sawh 195
Stretch/Photo
Snacks o Maskis
Gas & Go Ohom fmblasks) )22
Photo I NG
{2 ]0NG 2| B 2 =l 3= oMl 2| 2
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B/4/07 16:55 1 Forgus Fals MN  Gas & Go Gas P 2922 205
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Advanced Filter

Action

@ Filter the list, in-place
(8] Copy to another location

List range: SAS1:5)520 2]
8/4/07 5:45 1 Ali's house IL Last pick-up 0.00 >175 Criteria range: | $51:5)52] [2]
8/4/07 6:40 1 Toll Booth IL Alex Fumbles  Alltolls X 2.85 S —
Copy to: $AS27:5)527 2]
] Unique records only
oy
T S—
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8/4/07 9:00 1 Beloit WI Gas & Go Gas A 3450 241
8/4/07 12:05 1 St. Paul MN Gas & Go, Eat Gas P 2895 191 " -
8/4/07 16:55 1 FerqusFalsMN Gas&Go  Gas P 29.22 205 8/4/07 3:43| 1|Mfahoused.  [Iast piekup 000 |>175 [<235
8/5/07 7:25 2 Carrington ND Gas Gas A 37.42 252
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8/4/07 12:05 1 St. Paul MN Gas & Go, Eat Gas P 2895 191
8/4/07 16:55 1 Fergus Falls MN  Gas & Go Gas P 29.22 205
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